Wallpanal minimized

I’m a new user of WallPanel and bought a Samsung tab A (2019) 10 inch for displaying HA. WallPanel works very good but have one problem and I can’t find a solution.

In WP I enabled the camera for motion detection. If there is motion the screen will turn on with WP. This works good in the beginning but after some time the tablet doesn’t response on motion. When I tap twice on the screen I see the android lock screen and swipe to unlock.
When I unlock the homescreen appears and WP is running in the background. I can start WP and everything works again for some time.

I’ve searched in the android settings for disabling the lock screen but it looks like that doesn’t work. I set the screenlock on none. Also edited some battery saving options to ensure WP keeps running.
and did a factory reset. WP is the only extra installed app on the device.

Because WP didn’t work I’ve tested Fully Kiosk Browser and Fully Kiosk keeps running and there is no problem with turning the screen on with motion detection. But WP give’s me a better experience (less reloading) then Fully Kiosk Browser.

Information of my tablet
Tablet: Samsung Galaxy Tab A SM-T510
Android version 10
Kernalversion: 4.4.177-20048497
Android security patch 1 nob 2020

Does anybody have an idea how to solve this or how I can troubleshoot better?

You should disable the lock screen on your device and either use Google DayDream or the built in screensaver. It sounds as though your device is disconnecting the internet. The built-int screensaver prevents the device from sleeping, granted you disable the screensaver. You cannot use a lock screen with this application, that puts your device into sleep mode, and it can no longer function to send or receive MQTT commands.

Clear! I thought the screensaver wasn’t necessary. I enabled the screensaver and now the motion sensor keeps working but after a while WP is minimized when there is motion. The home screen is showing and WP has an orange 1 on the icon. WP is still running in the background.
Maybe the is something wrong in my settings?

I’m using the following settings (my tablet is in Dutch so I translated the android settings):
Android display settings
Time-out screen: 2 minutes
Screensaver: Colours
Type lockscreen: None

WallPanel settings
Prevent screen sleep: off
Screen brightness: off
Clock screensaver: off
Wallpaper screensaver: off
Start screensaver after: 2 minutes
Dim screen: 0%

Motion detection settings
Motion detection enabled: on
Wakes screen: on
Motion reset time: 15
Maximum leniency: 20
Minimum Luma: 1000